Question to say "I can!"

网站安全通用防护脚本分享,可修复漏洞

2013-10-29

其他都是虚的,这个才是最好的,即安全,又方便使用。绝对是中小站长们的必备武器。

 

各位亲,为更好的解决漏洞修复问题,我们提供了三种防护脚本:ASP、ASP.NET、PHP 。
有需要的可以下载用用,有问题的请联系我们哦。

主要功能:
拦截攻击者注入恶意代码,可以防御诸如跨站脚本攻击(XSS)、SQL注入攻击等恶意攻击行为。

更新日志:
2012年12月27日,更新正则表达式避免误报问题。
2013年1月8日,更新了asp防护脚本中referer变量冲突问题。
2013年1月9日,加入了UTF7编码XSS的防护。
2013年1月29日,增强了对XSS的防护。
2013年1月31日,针对某些用户后台上传文件出错的问题,更新了asp的防护代码。
2013年3月15日,增强了对POST的防护。
2013年3月28日,增强了对XSS的防护。
2013年4月25日,对XSS防护加入了通用的防护方法。
2013年7月12日,新增实时黑客攻击监控功能,定位黑客位置,防护规则增加20条。
2013年8月2日,加入对XSS编码绕过的防护。
2013年8月14日,增强利用样式的XSS防护。

PHP版本:
PHP版本的防护脚本我们做了升级强化,安装到网站之后,不仅可修复网站漏洞,还能实时监控黑客攻击,点这里下载:http://webscan.360.cn/protect/index/

 

ASP等其他版本:
 aspx360.zip (2.59 KB)

 asp360.zip (1.74 KB)

 

-----------------使用方法------------------------------------------------------------------

1.将360_safe3.asp传到要包含的文件的目录

2.在所需要防护的页面加入代码
<!--#include virtual="/360_safe3.asp"-->
就可以做到页面防注入、跨站
如果想整站防注,就在网站的一个公用文件中,如数据库链接文件conn.asp中!
添加<!--#include virtual="/360_safe3.asp"-->来调用本代码



作者:admin | Categories:互联网问题 | Tags:

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*

无觅相关文章插件,快速提升流量